Lo de Firefox parece ya de gruyere. A escasos 11 días del lanzamiento de su versión 1.0.6, ya son dos las vulnerabilidades críticas detectadas. La primera, el mismo día del lanzamiento, ya subsanada. La segunda acaba de ser anunciada por Secunia, afecta a todas las versiones 1.x y ha sido calificada de “extremadamente crítica”:

“Peter Zelezny has discovered a vulnerability in Firefox, which can be exploited by malicious people to compromise a user’s system.

The vulnerability is caused due to the shell script used to launch Firefox parsing shell commands that are enclosed within backticks in the URL provided via the command line. This can e.g. be exploited to execute arbitrary shell commands by tricking a user into following a malicious link in an external application which uses Firefox as the default browser (e.g. the mail client Evolution on Red Hat Enterprise Linux 4).

This vulnerability can only be exploited on Unix / Linux based environments.

The vulnerability has been confirmed in version 1.0.6 on Fedora Core 4 and Red Hat Enterprise Linux 4. Other versions and platforms may also be affected”.

La solución, por el momento y hasta que el equipo de Mozilla lance el parche (al menos, en esto sí son rapiditos), es no abrir enlaces en Firefox desde aplicaciones externas.

A ver si con la 1.5 (actualmente en fase beta) se solucionan todos estos problemas.

Actualización (21 sep-09.35 h): En esta ocaión el parche llega en formato de nueva versión, la 1.0.7, aunque por ahora sólo en inglés. Aunque ya puestos, también te puedes bajar la 1.5 beta.

Actualización (22 sep-17.18 h): Ahora sí. Ya está disponible la descarga en español para Windows, Linux y Mac.

Share