Andaba un tanto mosca con las revisiones a la baja que se estaban produciendo en mi PageRank (PR). Curioso, mientras el número de visitas, de enlaces y suscripciones prosigue en aumento, Google ha venido rebajando mi PageRank primero de 6 a 5 y ahora mismo entre 5 y 4. Pensé que podría ser un efecto del cambio de dominio, aunque eso ocurrió a principios de año. Pero no, Darren McLaughlin acaba de dar la voz de alarma: Democracy Ajax Poll Plugin, el hack que te permite insertar encuestas en ajax en WordPress, es más que probablemente el responsable de mi problema.

En pocas palabras: parece ser que el código del plugin contiene un error de sintaxis que obliga a los robots de Google a contar dos veces aquellas páginas en las que tengas habilitadas las encuestas, lo que se conoce como un Google Ick. Google penaliza duramente este tipo de conductas, pues lógicamente no sabe nada de este bug, sino entiende que el webmaster intenta engañarlo para aumentar su presencia y su nivel de PR. Y la penalización es clara: se reduce el PR del sitio en cuestión (a veces, definitivamente).

Andrew Sutherland, el autor del plugin (excelente, por otro lado), aún no se ha manifestado al respecto, pero Darren ofrece en su blog una solución de urgencia hasta que se lance una versión:

“Todo lo que el autor debería hacer es añadir una ‘/’ antes de ‘?jal_no_js=true&poll_id=11’ , de tal modo que la sentencia lleve a la raíz del directorio en lugar de añadirla al final de la URL. Igualmente se podría añadir una etiqueta ‘rel no follow’ y una orden de excluxión en ‘robots.txt”.

Supongo que se refiere a esta parte del código ‘/wp-content/plugins/democracy/democracy.php?jal_nojs=true’ que aparece en la línea 404 del archivo ‘democracy.php’, que debería quedar así: ‘/wp-content/plugins/democracy/democracy.php/?jal_nojs=true’. Yo, por si las moscas, he optado por eliminar el plugin.

Vía: The Blog Herald

Actualización (21 20 sep-00.10 h): Google Dirson publica un ilustrativo post en el que nos deja todo un poco más claro.

Share